Difference between revisions of "Notes on upgrading observatory computer to Windows 10, Summer 2020"

From Telescope
Jump to: navigation, search
Line 6: Line 6:
 
* Installed UltraVNC on both old and new computers so we can transfer files easily via VNC.  
 
* Installed UltraVNC on both old and new computers so we can transfer files easily via VNC.  
 
* Installed ASCOM platform 6.5 from [http://www.ascom-standards.org/ here].
 
* Installed ASCOM platform 6.5 from [http://www.ascom-standards.org/ here].
** As part of that installation, I found that the system required me to enable Microsoft .NET 3.5.  Ultimately that only worked when logged in to my normal user account, not the telescope account; probably related to trying to contact the local Windows Update server, but not being logged into the Swarthmore domain.
+
** As part of that installation, I found that the system required me to [https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10 enable Microsoft .NET 3.5 via the Control Panel].  Ultimately that only worked when logged in to my normal user account, not the telescope account; that is probably related to trying to contact the local Windows Update server, but not being logged into the Swarthmore domain.  It worked just fine from my domain account.
 
* Installed the ASCOM 2X mount adapter for TheSky (used to be called "TheSky-controlled telescope driver") from [https://www.bisque.com/downloads/ascom2xmount-adaptor-installer/ the Software Bisque site], linked from [https://ascom-standards.org/Downloads/ScopeDrivers.htm the ASCOM page].
 
* Installed the ASCOM 2X mount adapter for TheSky (used to be called "TheSky-controlled telescope driver") from [https://www.bisque.com/downloads/ascom2xmount-adaptor-installer/ the Software Bisque site], linked from [https://ascom-standards.org/Downloads/ScopeDrivers.htm the ASCOM page].
 
* The Edgeport/4 (USB-serial converter) - plug and play.  Windows recognized it right away and set it up automatically.  The COM ports show up in Device Manager as COM3, COM4, COM5, COM6, corresponding to ports 1-4 on the device.
 
* The Edgeport/4 (USB-serial converter) - plug and play.  Windows recognized it right away and set it up automatically.  The COM ports show up in Device Manager as COM3, COM4, COM5, COM6, corresponding to ports 1-4 on the device.
Line 16: Line 16:
 
# Based on last time, these programs can run into problems with Windows User Account Control, and need to be run as Administrator (at least once).  This sequence worked:  
 
# Based on last time, these programs can run into problems with Windows User Account Control, and need to be run as Administrator (at least once).  This sequence worked:  
 
#*  Right-click the RCOS-ae executable and then choose "Properties", and in that dialog, select "Run as administrator."  Answer "yes" in the resulting dialog about allowing the program to make modifications.  
 
#*  Right-click the RCOS-ae executable and then choose "Properties", and in that dialog, select "Run as administrator."  Answer "yes" in the resulting dialog about allowing the program to make modifications.  
#*  Do the same thing for the RCOS executable, choosing "Run as administrator."  
+
#*  Do the same thing for the RCOS executable, again choosing "Run as administrator."  
 
#*  Having done that once, it now works to simply double-click the RCOS executable - so something about that initial run sets things up to work on subsequent runs.   
 
#*  Having done that once, it now works to simply double-click the RCOS executable - so something about that initial run sets things up to work on subsequent runs.   
#  Connected to the telescope and tested this out - everything works!  This is set up as <code>COM3</code>.  
+
#  Connected to the telescope and tested this out - everything works!  The RCOS TCC is set up on <code>COM3</code>.  
 
* Next up is installing TheSkyX and getting that working.
 
* Next up is installing TheSkyX and getting that working.
  

Revision as of 08:39, 25 July 2020

Just as we did for the upgrade of the computer from Windows XP to Windows 7 in 2012, this page is to document the process of installing a new computer in the observatory, and noting any steps we need to take or problems we encountered. It is mostly for our own internal records, but perhaps it could help someone else installing observatory software as well.


Software installation

  • Installed UltraVNC on both old and new computers so we can transfer files easily via VNC.
  • Installed ASCOM platform 6.5 from here.
    • As part of that installation, I found that the system required me to enable Microsoft .NET 3.5 via the Control Panel. Ultimately that only worked when logged in to my normal user account, not the telescope account; that is probably related to trying to contact the local Windows Update server, but not being logged into the Swarthmore domain. It worked just fine from my domain account.
  • Installed the ASCOM 2X mount adapter for TheSky (used to be called "TheSky-controlled telescope driver") from the Software Bisque site, linked from the ASCOM page.
  • The Edgeport/4 (USB-serial converter) - plug and play. Windows recognized it right away and set it up automatically. The COM ports show up in Device Manager as COM3, COM4, COM5, COM6, corresponding to ports 1-4 on the device.
  • Now working on the RCOS TCC. This could be exciting as they went out of business and the software is so old. Fortunately we have good notes from the previous update.
  1. Download the full installation package (1.5.17) and the update (1.5.26) from the archived RCOS support site. I'm going to keep local copies of these installers this time, in case they disappear off the web.
  2. The last full installer there is 1.5.17, so download and install that first.
  3. Then download and copy over just the 1.5.26 RCOS-ae.exe file into the Program Files (x86) -> RCOS TCC folder, replacing the copy of RCOS-ae.exe in that folder.
  4. To get the presets from the old install, copy over the file RCOS.dat from the old installation. This has those values saved. There is also a file named RCOS-rotator.dat that I copied over, though I don't think we have saved much in the way of rotator settings.
  5. Based on last time, these programs can run into problems with Windows User Account Control, and need to be run as Administrator (at least once). This sequence worked:
    • Right-click the RCOS-ae executable and then choose "Properties", and in that dialog, select "Run as administrator." Answer "yes" in the resulting dialog about allowing the program to make modifications.
    • Do the same thing for the RCOS executable, again choosing "Run as administrator."
    • Having done that once, it now works to simply double-click the RCOS executable - so something about that initial run sets things up to work on subsequent runs.
  6. Connected to the telescope and tested this out - everything works! The RCOS TCC is set up on COM3.
  • Next up is installing TheSkyX and getting that working.

Hardware / system settings

  • Formatted D: drive as NTFS, named as "Telescope data".

To consider for later

  • Windows subsystem for Linux (enable via Control Panel - turn on features
  • Anaconda Python distribution